Помогите написать программу ** C++ Нужно сделать так чтобы она вычислила ариф выражение...

0 голосов
62 просмотров

Помогите написать программу на C++
Нужно сделать так чтобы она вычислила ариф выражение которое будет во вложении!
PS Нужно так же использовать метод присваивания, то есть допустим вы видим 3 корня, даем ему значение какой то переменной( то бишь упрощаем, дабы не писать везде 3 корня из)
Во вложении(выделил черным цветом)


image

Информатика (1.1k баллов) | 62 просмотров
0

и с чем у вас проблемы?

0

Не понимаю как именно это упросить и куда вводить формулу, именно с написанием ( порядком) проблемы. Знаю как это делается на теории, но как до практики доходит дело- облом...

Дан 1 ответ
0 голосов

#define _USE_MATH_DEFINES
#include
#include

int main()
{
    int x = 14;
    int y = 3;
    float pSqrtXY = pow(x + y, 1 / 3.0); //корень 3 степени из x+y
    float nSqrtXY = pow(x - y, 1 / 3.0); //корень 3 степени из x-y
    float FzpSqrtXYSqrtXY = pSqrtXY / nSqrtXY; // x+y/x-y
    float FznSqrtXYpSqrtXY = nSqrtXY / pSqrtXY; // x-y/x+y
    float A = pow(FzpSqrtXYSqrtXY + FznSqrtXYpSqrtXY - 2, 2); // A
    float sinPiX = sin(M_PI*x); // синус пи икс
    float cosPiX = cos(M_PI*x); // косинус пи икс
    float FzsinPiXnsqrtXY = sinPiX / nSqrtXY; // синус пи икс делить на x-y
    float fzcosPiXpsqrtXY = cosPiX / pSqrtXY; // косинус пи икс делить на x+y
    float tg2A = tan(2.0 * A); // тангенс 2A
    float B = (FzsinPiXnsqrtXY + fzcosPiXpsqrtXY)*tg2A; // B
    std::cout << "A = " << A << std::endl << "B = " << B << std::endl;<br>}

(1.5k баллов)