1. Составьте программу, которая вычисляет сред­нюю плотность раствора (в кг/м3) по...

0 голосов
123 просмотров
1. Составьте программу, которая
вычисляет сред­нюю плотность раствора (в кг/м3) по результатам из­мерения
плотности 7 проб (задаются в массиве кон­стант: 1205, 1350, 1170, 1320, 1220,
1310, 1180).

Информатика | 123 просмотров
Дано ответов: 2
0 голосов

Program nikitos1515;
const mas:array[1..7] of integer = (1205, 1350, 1170, 1320, 1220, 1310, 1180);
var i:integer;   
sredn:real;
begin
for i:=1 to 7 do
sredn:=sredn+mas[i];
sredn:=sredn/7;
writeln('Средняя плотность раствора =',sredn);
end.

(1.6k баллов)
0 голосов

Если решать с вашими константами:
program test;
uses crt;
var a:array [1..10] of integer;
i: integer;
rez:real;
begin
rez:=0;
a[1]=1205; a[2]=1350; a[3]=1170; a[4]=1320; a[5]=1220; a[6]=1310; a[7]=1180; 
for i:=1 to 7 do
rez:=rez+a[i];
rez:=rez/7;
write('rez = ',rez);
end.

Но, я предлагаю, чтобы пользователь сам вводил 7 значений, это так:
program test;
uses crt;
var a:array [1..10] of integer;
i: integer;
rez:real;
begin
rez:=0;
for i:=1 to 7 do
read(a[i]);
for i:=1 to 7 do
rez:=rez+a[i];
rez:=rez/7;
write('rez = ',rez);
end.

(5.4k баллов)
0

В твоих решениях нет констант вообще) Константы указываются в разделе описания констант - const. И тут нужно не предлагать свои варианты условия, а решать четко поставленную перед тобой задачу.

0

Не страшно)