Все Баллы отдаю Богом молю помогите написать программу ** языке С Дано число x....

0 голосов
57 просмотров

Все Баллы отдаю Богом молю помогите написать программу на языке С Дано число x. Напечатать в порядке возрастания Ln(x), 1+|x|, (1+x^2) x
P S Только не надо как обычно бред писать ради баллов


Информатика (417 баллов) | 57 просмотров
0

это систему надо решить? Могу на С++ написать, наверное

0

Ввести в графе значение x и чтобы выводила программа числа в порядке возрастания

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include

int main()
{
float x, y1, y2, y3; 
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1 if (y2 else printf("%f  %f  %f", y1,y3,y2);
}
else if ((y2 if (y1 else printf("%f  %f  %f", y2,y3,y1);
}
else if (y1 else printf("%f  %f  %f", y3,y2,y1);
return 0;
}

Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000

(194k баллов)