Составить программу которая заменяет все нечетные числа ** 31 массив из 15 целых чисел...

0 голосов
49 просмотров

Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20;30]


Информатика (148 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

Program Task;
Const n = 15;
Var a: Array [1..n] of Integer;
i: Integer;
Begin
    Randomize;
    For i := 1 To n Do
        a[i] := Random(30 - 20 + 1) + 20;
    WriteLn('Массив:');
    For i := 1 To n Do
        Write(a[i], ' ');
    WriteLn;
    For i := 1 To n Do
        If a[i] Mod 2 = 1 Then
            a[i] := 31;
    WriteLn('Результат:');
    For i := 1 To n Do
        Write(a[i], ' ');
    ReadLn;
End.

(2.8k баллов)