Помогите составить программу которая задает вопрос: "В каком году был основан город...

0 голосов
66 просмотров

Помогите составить программу которая задает вопрос: "В каком году был основан город Минск" (например: в 1067 г., либо в 1147 г .,). В случае верного ответа программа должна сообщить (Верно), в противном случае - (вы ошиблись)


Информатика (26 баллов) | 66 просмотров
Дан 1 ответ
0 голосов

С использованием кейсов. 


image
(404 баллов)
0

можно как нить по понятней?

0

а если без кейсов 8 класс информатика?

0

"begin и end." - тело программы, между ними выполняется весь код. "var input:smallint" - объявление локальной переменной с именем input и типом smallint(максимальное значение примерно 34к) Далее. writeln() выводим заданный текст. readln(input)

0

readln(input) - записываем введенные данные с клавиатуры в переменную input. Далее "case input of" проверяем значение переменной input. Ниже до "end;" все возможные варианты ввода.

0

Можно так же указать любой другой и вывести текст исходя из ответа.
Например: Если ввели 1067 выводится текст 'Верно'. "else" это если не один из вариантов не подошел.

0

То есть до else можно указать например: 1066 и вывести 'Вы почти угадали'.