Напишите программу ** паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1...

0 голосов
43 просмотров
Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток. Подсчитать общее количество цифр в этом числе.

Информатика (160 баллов) | 43 просмотров
0

Пожалуйста, помогите!!!!

Дан 1 ответ
0 голосов

Program test;
var i,n,schet:integer;s:string;
begin
readln(n);
for i:=1 to n do
s:=s+inttostr(n);
schet:=length(s);
writeln(schet);
end.

(623 баллов)
0

спасибо вам большое, вы меня спасли