Ребят помогите пж. Задача по информатике в паскале. Задача:Составить программу...

0 голосов
34 просмотров

Ребят помогите пж. Задача по информатике в паскале.
Задача:Составить программу вычисления суммы цифр числа, если кол-во неизвестно.


Информатика (12 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

Uses crt;
var a,b: Integer;
Begin
Write('Введите целое число: ');
Read a;
While a>0 do
Begin
b:=b+a mod 10;
a:=a div 10;
End;
Writeln('Сумма цифр введённого числа равна ', b);
End.

(411 баллов)
0

Спасибо