Нужно написать программу ** вход в pascal Программа получает 3 действительных числа-...

0 голосов
65 просмотров

Нужно написать программу на вход в pascal
Программа получает 3 действительных числа- значение градусных мер углов треугольника
1 программа должна проверить что это треугольник ( сложить 3 угла и получить 180)
2 программа должна вывести какой это треугольник( равнобедренный 2 угла равны, равносторонний все 3 угла равны 60, или прямоугольный угол 90)
3 если это прямоугольный треугольник то программа должна запросить 2 стороны треугольника ( 2 катета) и найти его площадь. ( площадь равна половине произведения катетов)
ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL ДАЮ 99 БАЛЛОВ!!


Информатика (136 баллов) | 65 просмотров
0

Можешь в одну программу объеденить

Дан 1 ответ
0 голосов
Правильный ответ

Uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Readln(a, b, c);
If (a+b+c)=180 then
Writeln('Это треугольник')
Else Writeln('Это не треугольник');
End.

Вторая:
uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Read(a,b,c);
If (a=b) or (a=c) or (b=c) then
Writeln('Треугольник равнобедренный');
End.

Третья:
uses crt;
var a,b,c: Integer;
d,e,f: Real;
Begin
Write('Введите три угла: ');
Readln(a,b,c);
If (a=90) or (b=90) or (c=90) then
Write('Введите два катета: ');
Readln(d,e);
f:=(d+e)/2;
Writeln('Площадь треугольника: ', f, '.');
End.

Если надо объединить в одну - пиши.

(411 баллов)
0

Нужно и на равнобедренный и на равносторонний. Тоесть программа должна показать тип любого треугольника

0

Writeln('Площадь треугольника: ', f, '.');

0

На эту жалуется

0

Тогда после строчки if (a=b) or (a=c) or (b=c) then пиши if (a=b=c) then Writeln('Треугольник равносторонний') | else

0

Что касается строчки, на которую жалуется: ты точно точь-в точь скопировал?

0

Э да

0

Ааа сори точку забыл

0

Спасибо огромное за помощь

0

Проверь. Теперь все нормально?

0

Да