Напишите программу ** языке Паскаль! С клавиатуры вводится три четырёх значных числа....

0 голосов
49 просмотров

Напишите программу на языке Паскаль!
С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе.


Информатика (12 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

Var
  a, b, c, sum: integer;

function min(x, y: integer): integer;
begin
  if(x > y) then result := y
  else result := x;
end;
 
begin
  sum := 0;
  read(a, b, c);
  a := min(a, min(b, c));
  while a > 0 do
  begin
    if(a mod 10 mod 2 <> 0) then sum := sum + a mod 10;
    a := a div 10;
  end;
  write(sum);
end.

(3.7k баллов)