Помогите написать программу, которая определяет, кратное ли число четырём. ** Pascal ABC...

0 голосов
86 просмотров

Помогите написать программу, которая определяет, кратное ли число четырём. На Pascal ABC и C++
Пример:
Ввод Вывод
32 Кратно 4
19 Не кратно 4


Информатика (35 баллов) | 86 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// Программа будет выполняться до тех пор,
// пока не будет введено "0"
var
    a : integer;
begin
    a := 1;
    while a <> 0 do begin
        write('>> '); read(a);
        if a mod 4 <> 0 then
            write('не ');
        writeln('кратно 4')
    end
end.



image
(5.6k баллов)
0 голосов

#include
using spacename std;
 void main(){
int a;

cin>> a;
if (a%4==0){
cout<<a<< "кратно 4";<br>}else{
cout<<a<<"не кратно 4";<br>}
  }





progeram p1;
uses crt; var a:integer; begin 
clrscr;read(a); 
write (a);if a mod 4 = 0 then 
 write("кратно 4"); 

else write ("не кратно 4");
readkey;
end.

(64 баллов)
0

На C++ у тебя не правильно)

0

writeln(a);

0

write("кратно 4");

0

почему?

0

ну вот проверь в С++

0

сори вечно забываю namespace

0

прости ряльно просто заторопился и забыл

0

ну что помогло?

0

чеееел, если пишешь 19, то выводит что оно кратно

0

в паскаль