Помогите написать программу ** с++ Надо вывести из строки со словами разделенными...

0 голосов
25 просмотров

Помогите написать программу на с++
Надо вывести из строки со словами разделенными пробелами , вывести слова в которых буквы не повторяются


Информатика (17 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;

int main()
{
    string S;
    cout << "BBEDITE TEXT: ", getline(cin,S);<br>    S+=' ';
    string Slovo = "";
    for (int i = 0; i < S.length(); i++)
    {
        if (S[i] != ' ') Slovo+=S[i];
        else
        {
            bool B = 1;
            for(int j = 0; j+1 < Slovo.length(); j++)
            {
                for(int m = j+1; m < Slovo.length(); m++)
                {
                    if (Slovo[j] == Slovo[m]) B = 0;
                }
            }
            if (B) cout<<"\n" <<Slovo;<br>            while (S[i] == ' ') i++;
            Slovo=S[i];
        }
    }
    return 0;
}

(6.6k баллов)