Написать программу,которая вычисляет сумму n- первых членов ряда 1+1/2+1/3+1/4+......

0 голосов
123 просмотров

Написать программу,которая вычисляет сумму n- первых членов ряда 1+1/2+1/3+1/4+... Количество суммируемых членов ряда задаётся во время работы программы.


Информатика (14 баллов) | 123 просмотров
Дан 1 ответ
0 голосов

Var
   n:integer;
   S:real;
Begin
Write('n = ');
ReadLn(n);
S:=0;
For n:= 1 to n do
    S:=S+1/n;
WriteLn('S = ',S)
End.

(6.6k баллов)