Помогите написать программу в паскале. Заранее спасибо)

0 голосов
32 просмотров

Помогите написать программу в паскале. Заранее спасибо)


image

Информатика (14 баллов) | 32 просмотров
0

данные о месяцах из фала доставать или в прогу можно забить?

0

В прогу забить можно

Дан 1 ответ
0 голосов

Program z21;  Var  n, days, a:integer; b,c:set of integer;Begin  write ('Введите номер месяца - '); readln (n);  write ('Введите признак года - '); readln (a);  b:= [1,3,5,7,8,10,12];  c:= [3,6,9,11];  if (n in b) then days:= 31;  if (n in c) then days:= 30;  if (n = 2) then if (a = 1) then days:= 29                            else days:= 28; writeln('Кол-во дней = ', days);End.

(832 баллов)
0

Спасибо)