Написать программу(pascal) которая вводит с клавиатуры числа А,B,C. найти ** сколько...

0 голосов
54 просмотров

Написать программу(pascal) которая вводит с клавиатуры числа А,B,C. найти на сколько увеличится за А лет B рублей положенная в банк если годовая прибыль составляет С процентов. (используя только mod div. 1 курс корочи) заранее спасибо


Информатика (12 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

Даже понятия не имею, к чему тут div и mod. Задача решается циклом for:

Var a,i:integer; b,c,b2:real;
Begin
 write('a='); readln(a);
 write('b='); readln(b);
 write('c='); readln(c);
 c:=c*0.01;
 b2:=b;
 for i:=1 to a do
   b2:=b2+(b2*c);
 b2:=b2-b;
 writeln('Ответ: ',b2:0:2);
End.

(472 баллов)
0

а там когда вводим например а=1

0

когда вводим а= (это типо год?)
b= сумма
с= проценты или что я н пойму объясни пож

0

Ты все верно понимаешь: a - количество лет, b - положенная в банк сумма, c - годовые проценты.

0

Если ввести a=1, то программа посчитает прибыль за 1 год =)