Помогите пожалуйста написать программу в паскале : символы, стоящие ** четных местах...

0 голосов
78 просмотров

Помогите пожалуйста написать программу в паскале : символы, стоящие на четных местах заменить на *. Пользоваться можно только: Pos,Insert,Delete,Length,Copy


Информатика (22 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

чесно говоря без них куда легче

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then s[i]:='*';

  writeln(s);

End.

 

с ними только больше кода

 

var s:string;

i:integer;

Begin

  read(s);

  for i:= 1 to length(s) do

    if i mod 2 = 0 then begin

      Delete(s,i,1);

      Insert('*',s,i);

    end;

  writeln(s);

End.

(53.1k баллов)