Помогите составить программу через с ++ номер 20

0 голосов
18 просмотров

Помогите составить программу через с ++ номер 20


image

Информатика (33 баллов) | 18 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include

using namespace std;
int main()

{

    int X,Y;

    cin>>X;

    if (X % 10 == 0)

        return 0;

    Y=((X % 10) * (X / 10) % 10) * 1000;

    Y=Y+((X % 10) % (X / 10)) * 100;

    Y=Y+(((X % 10) + (X / 10)) % (X % 10)) * 10;

   
Y=Y+(X / 10) % (X % 10);   
cout<<Y;}

(3.6k баллов)
0

пойдёт?