Помогите написать программу в паскале. задание 2.

0 голосов
33 просмотров

Помогите написать программу в паскале. задание 2.


image

Информатика (510 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

Var
  a: integer;
 
begin
  write('Введите чисдо a: ');
  readln(a);
  if(a = -1) then write('Число корней:', 1,'.', ' Корень: ' 'x=', 0,'.')
  else if(a + 1 < 0) then write('Число корней:', 0, ' (нет решения)')
  else write('Число корней:', 2,'.',' Корни:' ' x1=', sqrt(a + 1), ', x2=', -sqrt(a + 1),'.');
end.

(3.7k баллов)