Pascal написать программу вычисления суммы используя цикл До

0 голосов
82 просмотров

Pascal написать программу вычисления суммы используя цикл До


Информатика (19 баллов) | 82 просмотров
Дан 1 ответ
0 голосов

program sum;

  const p=100;

  var n:integer; s:real;

BEGIN

  S:=0;

  for  n:=1 to p   dо S:=S+n;

  writeln(‘s=’, s:7:2);

END.


uses crt;
var i:integer;
sum,s:real;
Beginclrscr;
i:=0;
while i<10 do <br>begin
i:=i+1;
sum:=exp(ln(i)*2);
s:=s+sum;
writeln('Сумма*=',s);
end;
еnd.
(14.5k баллов)