Помогите Написать программу, которая вводит с экрана N чисел, считает их среднее...

0 голосов
52 просмотров

Помогите Написать программу, которая вводит с экрана N чисел, считает их среднее арифметическое и выводит его на экран


Информатика (12 баллов) | 52 просмотров
Дан 1 ответ
0 голосов

Program;
var a,sum,k:integer;
      sr:real;
Begin
sum:=0;
k:=0;
while a<>0 do
begin
read(a);
sum:=sum+a;
k:=k+1;
end;
sr:=sum/k;
writeln(sr);
End.

(208 баллов)
0

не работает

0

ща проверю

0

странно у меня все работает