Написать программу для Паскаля. Вывести ** экран все числа до 1000, количество делителей...

0 голосов
49 просмотров

Написать программу для Паскаля. Вывести на экран все числа до 1000, количество делителей которых больше чем 5


Информатика (20 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
Program hhh54;
var i,j,k: longint;
begin
  for i:=1 to 1000 do
    begin
      k:=0;
      for j:= 1 to i do
        if i mod j =0 then k:=k+1;
      if k > 5 then writeln (i);
    end;
end.
(5.3k баллов)