Напишите программу ** c#Дано натуральное число. Верно ли, что в данном числе нет цифры A....

0 голосов
64 просмотров

Напишите программу на c#
Дано натуральное число. Верно ли, что в данном числе нет цифры A. A задается


Информатика (96 баллов) | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.Write("Введите натуральное число: ");
            int C = int.Parse(Console.ReadLine());
            Console.Write("A = ");
            int A = int.Parse(Console.ReadLine());
            while (C > 0)
            {
                if (C % 10 == A) A = -1;
                C /= 10;
            }
            Console.WriteLine((A > -1?"Верно":"Не верно"));
            Console.ReadKey();
        }
    }
}

(6.6k баллов)