Написать программу в с# двумерный массив В двумерном массиве хранится информация о...

0 голосов
41 просмотров

Написать программу в с# двумерный массив

В двумерном массиве хранится информация о количестве учеников каждом из четырех классов каждой параллели школы с первой по одиннадцатую(в первой строке – информация о первых классах, во второй – вторых и т. д.). Найти численность самого большого класса среди 10-х и 11-х классов.


Информатика (15 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;
public class Test
{
public static void Main()
{
int[,] a=new int[11,4];
Random rnd=new Random();
Console.WriteLine("");
Console.WriteLine("исходный массив");
for(int i=0;i<11;i++)<br> {
for(int j=0;j<4;j++)<br> {
a[i,j]=rnd.Next(10,30);
Console.Write(a[i,j]+" ");
}
Console.WriteLine("");
}
int max=-1;
for(int i=9;i<11;i++)<br> for(int j=0;j<4;j++)<br> if(a[i,j]>max) max=a[i,j];
Console.WriteLine("самый большой среди 10-11: "+max);
}
}

(149k баллов)
0

а почему не пользуетесь данными о длине массива? почему константы? а вдруг поменяется что

0

так в задание уже задано,что есть 4 параллели и 11 классов

0

вот и используйте это один раз а в остальном лучше писать a.Length или a.GetLength(0) точно не помню, но не константа от руки

0

учту ваше замечние и в следущий раз буду писать правильно

0

public static void Main()
{
var a = new int[11, 4];
var rnd = new Random();

Console.WriteLine("исходный массив");
for (var i = 0; i < a.GetLength(0); i++)
{
for (var j = 0; j < a.GetLength(1); j++)
{
a[i, j] = rnd.Next(10, 30);
Console.Write($"{a[i, j]} ");
}

Console.WriteLine();
}

var max = -1;
for (var i = 9; i < a.GetLength(0); i++)
for (var j = 0; j < a.GetLength(1); j++)
if (a[i, j] > max) max = a[i, j];

Console.WriteLine($"Cамый большой среди 10-11: {max}");
Console.ReadLine();
}