.Помогите пожалуйста очень срочно.Написать программу в любой программе(лучше всего **...

0 голосов
53 просмотров

.Помогите пожалуйста очень срочно.Написать программу в любой программе(лучше всего на сишарп), которая преобразует целое положительное десятичное число (число разрядов не более 6) в его эквивалент в 2 систему счисления. Программа должна вводить число в 10 систему счисления и печатать результат в 2 системе счисления. Например:

Введите целое число в 10c/c: 12

Двоичный эквивалент равен 1100

Незначащие нули должны подавляться. Должен быть контроль вводимых цифр. Разрешены цифры 0 - 9.


Информатика (15 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

function Dec2Bin(x:string):string;
begin
  var s:=x.MatchValue('\d+');
  if s.Length=0 then begin
    Writeln('Не найдено НИ ОДНОЙ цифры!');
    Result:=''
    end
  else begin
    var t:=s.ToInteger;
    var r:string:='';
    while t>=2 do (r,t):=(t mod 2+r,t shr 1);
    Result:=t+r
    end
end;

begin
  Writeln(Dec2Bin(ReadlnString('n=')))
end.

(150k баллов)
0

Program1.pas(5) : Встречено ',', а ожидалось ')'

0

Result:=t+r И В ЭТОЙ СТРОКЕ ТОЖЕ ВЫДАЁТ ОШИБКУProgram1.pas(6) : Встречено 'Result', а ожидалось ')'

0

как ее обновить?