Составить программу, по которой выведется значение true, если точка с заданными...

0 голосов
177 просмотров

Составить программу, по которой выведется значение true, если точка с заданными координатами (x,y) лежит внутри заштрихованной области и false – в противном случае.


image

Информатика (58 баллов) | 177 просмотров
Дан 1 ответ
0 голосов

Примерно так, но не очень уверен, т.к. чертеж не понятен полностью.

var otvet:boolean;
      x,y:integer;
begin
readln(x,y);
otvet:=((x in [3..4]) and ((y in [3..4]) or (y in [-4..-3])));
writeln(otvet);
end.

(1.6k баллов)
0

Спасибо, но это не совсем то, что нужно)

0

Программа выведет False если точки не принадлежат заштрихованной области, иначе выведет True)

0

мы уже составляли подобную программу, но там была другая фигура) у меня есть записи этой программы, но я не могу понять какое ограничение нужно поставить для данной фигуры)

0

Если условие указано верно, то решение верное)

0

;)

0

На рисунке видим, что фигура может принимать на оси x значения от 3 до 4, и на оси y от -4 до -3 в объединении с промежутком от 3 до 4