Написать программу , которая вычисляет расстояние между точками A(x₁,y₁) и B(x₂,y₂) с...

0 голосов
72 просмотров

Написать программу , которая вычисляет расстояние между точками A(x₁,y₁) и B(x₂,y₂) с точностью до 0,1 по формуле AB=√(X₂-X₁)²+(Y₂-Y₁)². Язык программирования PASCAL.
P.S. (X₂-X₁)²+(Y₂-Y₁)² полностью под корнем


Информатика (111 баллов) | 72 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   Ax,Ay,Bx,By:real;
Begin
WriteLn('Точка A:');
Write('   x: ');ReadLn(Ax);
Write('   y: ');ReadLn(Ay);
WriteLn('Точка B:');
Write('   x: ');ReadLn(Bx);
Write('   y: ');ReadLn(By);
WriteLn('|AB| = ',Sqrt(Sqr(Bx-Ax)+Sqr(By-Ay)):0:1);
End.

(6.6k баллов)