Информатика(Pascal). Составить программу нахождения наименьшего общего кратного(НОК) двух...

0 голосов
129 просмотров

Информатика(Pascal). Составить программу нахождения наименьшего общего кратного(НОК) двух чисел m и n, используя формулу n*m=НОД(n,m)* НОК (n,m).


Информатика (158 баллов) | 129 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses crt;
var n,m,p : real;
nod,nok : real;
begin
clrscr;
write('n=');readln(a);
write('j=');readln(b);
p:=n*m;
while n<>m do
if n>m then n:=n-m
else m:=m-a;
nod:=n;
nok:=p/nod;
writeln('НОД:',n);
write('НОК:',nok);
readln;
end.

(232 баллов)
0

Вместо а -n поставь.
Всесто b -m поставь.
Я привыкла работать с а и б

0

а понял,спс

0

а модуль clrscr обязателен?

0

а всё,убрал его , всё норм теперь, не подскажешь зачем его используют вообще?

0

Не за что

0

Не очень. Он позволяет выводить цветные символы цветными

0

понял, странно что мы этого вроде ещё не проходили,хотя может я забыл, ты же в 9?

0

Сказано ведь в задании "по формуле...", и приведена формула. А здесь совсем не так.

0

ФВС помоги с новой задачкой пж

0

там в информатике близко