Нужно написать программу, которая удаляет из строки все цифры ** паскале.

0 голосов
116 просмотров

Нужно написать программу, которая удаляет из строки все цифры на паскале.


Информатика (17 баллов) | 116 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Вводите:').MatchValues('[^\d]').JoinIntoString('');
  Write('Получим: '); s.Println
end.

Пример
Вводите: Пусть 2.5*x+sin(x/2)=2.054. Отсюда найдем х и вычислим x^(2/3).
Получим: Пусть .*x+sin(x/)=.. Отсюда найдем х и вычислим x^(/).

(150k баллов)
0 голосов

Ответ:::::::::::::::::::::::

(3.7k баллов)