Язык программирования С (Си) Составить программу, анализирующую нажатую кнопку ** ее...

0 голосов
53 просмотров

Язык программирования С (Си)
Составить программу, анализирующую нажатую кнопку на ее принадлежность к определенной группе клавиш. Соответствующие сообщения выдаются для цифровых клавиш, больших латинских букв, малых латинских букв, больших букв и малых букв латинского алфавита


Информатика (868 баллов) | 53 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
int main(int argc, char *argv[])
{
    int C = getch();
    if ('0'<=C&&C<='9') printf("0..9");<br>    else if(('a'<=C&&C<='z')||('A'<=C&&C<='Z')) <br>             printf("Latinskie%s",('a'<=C&&C<='z'?"[a..z]":"[A..Z]"));<br>}

(6.6k баллов)