В паскале написать программу, которая вычисляет y по формуле y=√ab. В случае когда ab<0 выводить на экран "решения нет". Заранее спасибо
BEGIN writeln('Введите А, В:'); readln(a, b); if (a*b < 0) then write('решения нет'); else write(sqrt(a*b)); END.
Неверное условие: должно быть >=
Прошу прощения, у Вас всё правильно. Я ошибся!