Помогите пожалуйста написать программу в Паскале. Задание 2.

0 голосов
27 просмотров

Помогите пожалуйста написать программу в Паскале. Задание 2.


image

Информатика (277 баллов) | 27 просмотров
0

"Вычислить произведение значений функции для аргументов крат.." а дальше?

0

Для аргументов красных m.

0

Кратных *

0

Помогите пожалуйста сделать

0

Что значит "3^2(тут вроде бы квадрат <= x <= 33^(тут неизвестно что))" ?

0

Там не в квадрате, а градус

0

Помогите)

Дан 1 ответ
0 голосов

Var
   x,x0,xn,m,h:integer;
   a,y,P,R:real;
Begin
Write('Введите начало диапазона: ');ReadLn(x0);
Write('Введите конец диапазона: ');ReadLn(xn);
Write('m = ');ReadLn(m);
Write('a = ');ReadLn(a);
Write('h = ');ReadLn(h);
P:=1;
x:=x0;
Repeat
R:=x*Pi/180;
y:=(Cos(R)+Sqr(Sin(R)))/(a+Cos(R*R));
if x mod m = 0 then P:=P*y;
WriteLn('y(',x,') = ',y);
x:=x+h;
Until x > xn;
WriteLn('P = ',P);
ReadLn
End.

(6.6k баллов)