Помогите пожалуйста написать программу в Паскале. 3 номер.

0 голосов
28 просмотров

Помогите пожалуйста написать программу в Паскале.
3 номер.


image

Информатика (277 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Var
   x,S,St:real;
   n:integer;
Begin
Write('x = ');ReadLn(x);
S:=0;
St:=1;
For n:= 1 to 15 do
    Begin
    St:=St*Sin(x);
    if n mod 2 <> 0 then S:=S-2*n/St
    else S:=S+2*n/St
    End;
WriteLn('S = ',S);
End.

(6.6k баллов)