Помогите написать программу в Паскале. Дано вещественное число А и целое N(N>1).вывести...

0 голосов
49 просмотров

Помогите написать программу в Паскале.
Дано вещественное число А и целое N(N>1).вывести в табличном виде все целые степени числа А от 1 до N.


Информатика (277 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

Var
   A,St:real;
   N,L:integer;
Begin
Write('A = ');ReadLn(A);
Write('N = ');ReadLn(N);
St:=1;
For n:= 1 to N do
    Begin
    St:=St*A;
    WriteLn(A,'^',n,' = ',St)
    End;
End.

(6.6k баллов)