Помогите составить программу ** языке паскаль: Вычислить значение выражения: f(x)=ctg...

0 голосов
29 просмотров

Помогите составить программу на языке паскаль:
Вычислить значение выражения: f(x)=ctg 3x*log(2x+3)*4 при любых значениях х.
Прошу 16 баллов!


Информатика (12 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

Первый вариант: если десятичный логарифм от (2x+3).

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Нельзя вычислить логарифм от нуля!')<br>else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(2*x+3)*4/(Tan(3*x)*Ln(10)))
End.



Второй вариант: если логарифм по основанию (2x+3) от 4.

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Основание логарифма должно быть больше нуля!')<br>else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(4)/(Tan(3*x)*Ln(2*x+3)))
End.

(6.6k баллов)