Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3%...

0 голосов
302 просмотров

Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% — если сумма больше 1000 руб. (C#)


Информатика (23 баллов) | 302 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.Write("Сумма покупки: ");
            double S = int.Parse(Console.ReadLine());
            if (S > 500)
            {
                if (S > 1000) S *= 0.95;
                else S *= 0.97;
                Console.WriteLine("Сумма покупки с учётом скидки: {0:0.00}",S);
            }
            else Console.WriteLine("Скидка не предоставляется");
            Console.ReadKey();
        }
    }
}

(6.6k баллов)