// Решение нужно ** языке программирования C++. Задан номер мобильного телефона....

0 голосов
54 просмотров

// Решение нужно на языке программирования C++.
Задан номер мобильного телефона. Определить, какие цифры отсутствуют в этом номере.
Входные данные: в единственной строке задан номер мобильного телефона.
Выходные данные: в первой строке вывести количество отсутствующих в номере цифр. Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.


Информатика (15 баллов) | 54 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
#include

using namespace std;
int main()
{
    string s;
    cin >> s;
    set mySet;
    set::iterator it;
    for(char i='0'; i<='9'; i++) mySet.insert(i);<br>    for(int i=0; i    cout << mySet.size() << endl;<br>    for(it=mySet.begin(); it!=mySet.end(); ++it)
        cout<<*it<<" ";<br>    return 0;
}

Пример:
74959741926
3
0 3 8

(194k баллов)