Напишите программу ** паскале срочно! Ученики 4 класса вели дневники наблюдения за...

0 голосов
159 просмотров

Напишите программу на паскале срочно!
Ученики 4 класса вели дневники наблюдения за погодой в апреле и ежедневно записывали дневную температуру. Данные заносили в массив размерностью 30. Данные в диапазоне от -10 до 10 градусов.
1. Найдите среднюю температуру для дней, когда столбик термометра поднимался выше нуля градусов.
2. Определите количество таких дней. Если их нет, то выведите No.
3. Определите день с самой низкой температурой, выведите в формате <<номер>> дня <<апреля>>.


Информатика (74 баллов) | 159 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Если срочно, то вот так:
begin
  Writeln('Температура апреля:');
  var a:=ArrRandom(30,-10,10); a.Println;
  var sr:=a.Where(x->x>=0).Average;
  Writeln('Средняя температура для дней, когда >0 = ',sr:4:1);
  var k:=a.Where(x->x>=0).Count;
  if k=0 then writeln('No')
  else Writeln('Количество дней с температурой >0 = ',k);
  Writeln('Самая низкая температура: ',a.IndexMin+1,' день апреля');
end.

Пример:
Температура апреля:
-3 -5 9 7 0 -7 -3 8 -5 9 -5 1 -8 3 0 3 -2 -7 9 4 2 -4 -10 7 1 7 4 3 6 -2
Средняя температура для дней, когда >0 =  4.6
Количество дней с температурой >0 = 18
Самая низкая температура: 23 день апреля

(194k баллов)