Срочно Помогите пожалуйста Написать программу ** языке программирования Паскаль 1)зная...

0 голосов
60 просмотров

Срочно
Помогите пожалуйста
Написать программу на языке программирования Паскаль
1)зная температуру воздуха ,определить вид осадков (дождь или снег)
2)найдите сумму цифр заданного трехзначного числа
3)если первое число больше второго ,то определить квадрат меньшего числа ,а в противном случае - произведение чисел


Информатика (57 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   t:integer;
Begin
Write('Введите температуру воздуха: ');ReadLn(t);
if t > 0 then Write('Дождь')
else Write('Снег')
End.



Var
   A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
A:=Abs(A);
WriteLn(A div 100,'+',(A div 10) mod 10,'+',A mod 10,' = ',A div 100+(A div 10) mod 10+A mod 10);
End.



Var
   A,B:integer;
Begin
Write('Введите два числа: ');ReadLn(A,B);
if A>B then Write('Квадрат меньшего: ',B*B)
else Write('Произведение чисел: ',A*B)
End.

(34.0k баллов)