Помогите!Тема: Циклы Нужно нарисовать блок схему и написать программу ** языке...

0 голосов
37 просмотров

Помогите!Тема: Циклы
Нужно нарисовать блок схему и написать программу на языке ТурбоПаскаль
Если не сложно, то по подробнее!
Во вложении


image

Информатика (1.1k баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Блок-схемы - в прилагаемом файле.
Программы:
1)
program p2;
var i:integer;
begin
for i:=30 to 40 do write(i,' ');
readln;
end.

Результат:
30 31 32 33 34 35 36 37 38 39 40

2)
program p1;
var i:integer;
begin
for i:=40 downto 30 do write(i,' ');
readln;
end.

Результат:
40 39 38 37 36 35 34 33 32 31 30


image
(194k баллов)