Помогите составить программу!!Нужно составить программу ** Pascal! Задача: Вычислить 

0 голосов
25 просмотров

Помогите составить программу!!Нужно составить программу на Pascal!

Задача: Вычислить
x-x^3/3!+x^5/5!-x^7/7!+x^9/9!-x^11/11!


Информатика (89 баллов) | 25 просмотров
0

Эту задачу решают постоянно, решена уже сотни раз на всех языках..

0

Вы, кстати в конце +x^13/13! не дописали

0

ее там не должно быть

0

Ну тогда это совсем другая задача. Поисковиком её не найти...

0

сумма гармонического ряда, тоже мне

Дан 1 ответ
0 голосов
Правильный ответ

Если (n - 1)-ое слагаемое равно y, то n-ое слагаемое равно -y * x^2 / (2n * (2n + 1)). Осталось положить первое слагаемое равным x и просуммировать 6 раз.

PascalABC.NET 3.2
begin
  var x := readReal;
  var y := x;
  var s := x;
  var n := 1;
  while (n < 7) do
  begin
    y := -y * x * x / (2 * n) / (2 * n + 1);
    s += y;
    n += 1;
  end;
  writeln(s);
end.

Пример ввода: 1
Пример вывода: 0.841470984808658

(148k баллов)
0

чисто интереса ради, а зачем вайл? или переписаный шаблон?