** вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6...

0 голосов
242 просмотров

На вход программе подаются два целых числа m и n, по модулю не превосходящие 10 в 6 степени. Если m делится на n или n делится на m, то требуется вывести 1, в противном случае - любое другое число.


Информатика (753 баллов) | 242 просмотров
0

Паскаль? Бейсик? Си?

0

паскаль

Дан 1 ответ
0 голосов

Var n,m:longint;
Begin
Read(n,m);
Write((n mod m)*(m mod n)+1)
End.

(6.6k баллов)
0

Если делится - единицу, в противном случае - всё, что угодно, кроме единицы.

0

вы уверены ,что это правильное решение?

0

Любое, и случайное - разные вещи\\ Да, уверен.

0

Хорошо. Спасибо

0
Это неправильный ответ. Введите 5 и 2 и убедитесь. Не вводите людей в заблуждение.