Напишите программу на языке Паскаль!!! На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем числе.
Var a, b, n: integer; sr: real; begin sr := 0; n := 0; read(a, b); if(a > b) then a := b; while a > 0 do begin if((a mod 10) mod 2 = 0) then begin sr := sr + a mod 10; n := n + 1; end; a := a div 10; end; write(sr / n); end.
Попробуйте скачать последнюю версию PascalABC.NET.
Она у меня и стоит
Версия 3.2.0.1443?Если нет то обновите.
Что делать ? Он просто пишет Nan
У меня самая последняя версия
От какого числа сборка?
Я без понятия
Школьный компьютер
Спасибо Огромное
Все работает