В книге ** одной странице помещается k строк. Написать программу в паскале которая по...

0 голосов
114 просмотров

В книге на одной странице помещается k строк. Написать программу в паскале которая по номеру строки в тексте выводит на какой странице она находится и на какой строке.
спасибо


Информатика (881 баллов) | 114 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Если на странице k строк, то первая строка на первой странице имеет номер 1, на второй k + 1, на третьей 2k + 1, а четвертой 3k + 1 и т.д. Значит, если есть строка с номером x, то уже (x - 1) div k страниц полностью заполнены, эта строка находится на ((x - 1) div k + 1)-ой странице на ((x - 1) mod k + 1)-ом месте.

var
  k, x: integer;
begin
  read(k, x);
  write((x - 1) div k + 1, ':', (x - 1) mod k + 1)
end.


(148k баллов)