Напишите программу в паскаль: составить программу для получения в порядке убывания всех...

0 голосов
96 просмотров

Напишите программу в паскаль:

составить программу для получения в порядке убывания всех делителей данного числа


Информатика (263 баллов) | 96 просмотров
Дан 1 ответ
0 голосов

program Divisors;

var

N,i: integer;

begin

readln(N);

for i:=N downto 1 do if N mod i = 0 then write(i,' ');

end.

(186 баллов)