Написать программу которая выводит целые числа в промежутке от 1 до 50,кратные восьми и...

0 голосов
59 просмотров

Написать программу которая выводит целые числа в промежутке от 1 до 50,кратные восьми и считает их количество , суммы и произведение . В языку паскаля .


image

Информатика (22 баллов) | 59 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var i,k,s:integer; p:longint;
begin
k:=0; s:=0; p:=1;
for i:=1 to 50 do
 if i mod 8 = 0 then
  begin
  write(i,' ');
  k:=k+1;
  s:=s+i;
  p:=p*i;
  end;
 writeln;
 writeln('k = ',k,' s = ',s,' p = ',p);
 end.

Результат:
8 16 24 32 40 48 
k = 6 s = 168 p = 188743680

(194k баллов)
0

надеюсь правильно