Напишите программу для Паскаля АБС (старая версия) Сумма от 1 до 5 Написать Сумма_пока...

0 голосов
29 просмотров

Напишите программу для Паскаля АБС (старая версия)
Сумма от 1 до 5 Написать Сумма_пока
То есть вид программы Сумма_пока
While по-английски


Информатика (1.5k баллов) | 29 просмотров
0

Есть формула для таких сумму: n*(n+1)/2 = 5*(5+1)/2 = 15

Дан 1 ответ
0 голосов
Правильный ответ

Var S,i:integer;
Begin
S:=0;
i:=1;
While i <= 5 do<br>   Begin
   S:=S+i;
   i:=i+1
   End;
WriteLn('S = ',S);
End.

(6.6k баллов)