Написать программу для вычисления суммы 10+20+30+...+400. Программа: PascalABC

0 голосов
72 просмотров

Написать программу для вычисления суммы 10+20+30+...+400.
Программа: PascalABC


Информатика (315 баллов) | 72 просмотров
0

можно с циклами repeat, while, for...

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(10,400,10).Sum);
end.

Результат
8200

2. С циклом while

begin
  var n:=10;
  var s:=0;
  while n<=400 do begin s+=n; n+=10 end;<br>  Writeln(s);
end.
(150k баллов)
0

Спасибо!