Напишите программу сложения, вычитания и умножения двух двоичных чисел. Предложите способ...

0 голосов
59 просмотров

Напишите программу сложения, вычитания и умножения двух двоичных чисел. Предложите способ проверки результата: 1011 и 110


Информатика (17 баллов) | 59 просмотров
Дан 1 ответ
0 голосов

Const
  Rn : String[36] = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ';

Function DecToN(a : Longint; Raz : Byte) : String;
Begin
  If a>Raz-1 then DecToN:=DecToN(a div Raz,Raz)+Rn[(a mod Raz)+1]
  else DecToN:=Rn[a+1];
end;

Function NToDec(a : String; Raz : Byte) : Longint;
Begin
  If Length(a)>0 then NToDec:=Pos(a[Length(a)],Rn)-1+Raz*NToDec(Copy(a,1,Length(a)-1),Raz)
  else NToDec:=0;
end;

Var a,b : String;
Begin
  a:='1011'; b:='110';
  Writeln('a = ',a,' (bin) = ',NToDec(a,2),' (dec)');
  Writeln('b = ',b,' (bin) = ',NToDec(b,2),' (dec)');
  Writeln(a+'+'+b+' = ',DecToN(NToDec(a,2)+NToDec(b,2),2),' (bin)  ',NToDec(a,2)+NToDec(b,2),' (dec)');
  Writeln(a+'-'+b+' = ',DecToN(NToDec(a,2)-NToDec(b,2),2),' (bin)  ',NToDec(a,2)-NToDec(b,2),' (dec)');
  Writeln(a+'*'+b+' = ',DecToN(NToDec(a,2)*NToDec(b,2),2),' (bin)  ',NToDec(a,2)*NToDec(b,2),' (dec)');
end.

(5.1k баллов)
0

Строка нужна для перевода из одной СС в другую. Потом происходит математическая часть с последующим переводом результата в изначальную двоичную систему.

0

просто функция более универсальная... но да, можно немного и сократить при желании

0

Я же говорю - функции мои, готовые, сделанные для универсального использования. Я просто беру готовые блоки и "склеиваю" под свои нужды. Даже если алфавит будет 2-ух символьным - это сократит код мизерно. Я конечно понимаю, что Вы возможно перфекционист, но моё решение именно такое и еще больше его оптимизировать смысла не вижу. Хотите предложить лучше? Милости просим! Я только "ЗА", чтобы все могли увидеть несколько разных подходов к решению.