Напишите программу, которая заполняет массив из 20 элементов натуральными числами и...

0 голосов
36 просмотров

Напишите программу, которая заполняет массив из 20 элементов натуральными числами и считает разность произведений четных и нечетных элементов массива(paskal)


Информатика (15 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var 
b: array[1..20] of BigInteger; 
pr, pr1, raz: BigInteger;

begin 
pr := 1; 
pr1 := 1; 
for var i := 1 to 20 do 
begin   
b[i] := random(100) + 10;   
write(b[i]+' ');   
if b[i] mod 2 = 0 then      
pr := pr * b[i];   
if b[i] mod 2 <> 0 then      
pr1 := pr1 * b[i];   
raz := pr - pr1; 
end; 
writeln(); 
writeln('Разница равна ', raz);
end.
(314k баллов)