ПОМОГИТЕ ПОЖАЛУЙСТА Напишите программу которая считает из файла input.txt целое число,...

0 голосов
51 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА

Напишите программу которая считает из файла input.txt целое число, определяет является ли оно простым и записать результат в файл output.txt


Информатика (294 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var f1,f2:text; a,i,k:integer;
begin
assign(f1,'input.txt');
reset(f1);
assign(f2,'output.txt');
rewrite(f2);
readln(f1,a);
k:=0;
for i:=2 to round(sqrt(a)) do 
 if a mod i=0 then k:=k+1;
if k=0 then writeln(f2,a,' - простое число')
else writeln(f2,a,' - составное число');
close(f1); close(f2);
end.

Пример:
Файл input.txt:
43
Файл output.txt:
43 - простое число

(194k баллов)
0

Спасибо большое)))

0

Пожалуйста.