Напишите программу ** языке паскаль. Надо заменить меньшее из двух данных чисел ** их...

0 голосов
31 просмотров

Напишите программу на языке паскаль. Надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее геометрическое.


Информатика (163 баллов) | 31 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a, b,sa,sg: real;

begin
  write('Введите a ');readln(a);
  write('Введите b ');readln(b);
  sa:=(a + b) / 2;
  sg:=sqrt(a * b);
  if a < b then begin
    a := sa;
    b := sg;
  end
  else begin
    a := sg;
    b := sa;
  end;
  writeln('a= ', a:0:2, ' ', 'b= ', b:0:2);
end.

(314k баллов)
0

спасибо!!!

0

обнови там была ошибка

0

спасибо